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Part V - Creating a Path Extruded Object

Path extrusion is the process where a 2-D contour is
swept along a designated path to make pipes, joints, and elongated 
3-D forms quickly and easily. In this example, you will draw a pipe
through two donut-shaped collars.

Getting Started

In Part IV, you will use the Spline, Torus,
Ellipse and the Path Extrude tools for design and the Clone
and Move To commands to duplicate and accurately place
objects. You will use the spline to draw a tube created from a
path extruded circle through two adjacent toruses. 

If you are not in ModelPro, launch ModelPro by double-
clicking on its icon. If you are in ModelPro, select New
under the File Menu to start with a fresh drawing
environment.

Preparing the Drawing Environment

In this part of the tutorial, we want direct access to all
objects and do not want them placed automatically in a folder after a 
3-D operation. Select the Edit menu and choose Preferences to display
the General dialog. The box next to 3-D Operations Create Folders
should be un-checked. If it’s checked, click in the box and click in the
OK box. If it’s un-checked, click in the OK box.

Placing the Torus

Select the Torus Primitive by clicking and holding on
the Cube Primitive to show the 3-D primitives pop-up. Drag over to the
Torus at the end of the pop-up and release. To draw the torus, place the
cursor at the Galactic Core (0,0,0), where the two Origin Lines meet.
While holding the Shift key down, click, hold and drag down 
and to the right until the torus has an outer diameter of slightly less than
one inch.

Use the Selector Tool to select the torus if it is not already selected.
Under the Operations Menu, select Move To to display the Move To
dialog. Click on the center of the Object Extent Box, the small, empty
square in the center of the Object Extent Box. This sets the front-center
of the torus as the point on the object to be moved. 

Move To dialog for torus

Note: The shift key constrains the torus
to a circular shape.

Note: The Object Extent Box can be
set at three positions; Front, Middle,
and Back. Click on the Section pop-up
to select another position.



The torus is to be moved so it is sitting evenly on the X-axis,
its center one inch to the right of the vertical Origin Line.
Type 1 in the X box of the Move To data fields, 0 in the 
Y Box, and the value of Z shown under the Current
Location. The Z value stays the same because we are making
a lateral move in the Front View and not moving the torus in
or out. Click OK to automatically re-position the torus.

Placing the Second Torus

Use the Selector Tool to select the torus if it
is not already selected. Under the Edit Menu, select Clone to
make a copy of the torus. The copy will be drawn right on top
of the first torus. Under the Operations Menu, select Move
To to display the Move To dialog. Click on the center of the
Object Extent Box.

The torus is to be moved so it is at the same height as the first
torus, but on the other side of the X-axis, its center one inch
to the left of the vertical Origin Line. Type -1 in the 
X box of the Move To data fields, the other values remain 
the same. Click OK to automatically re-position the torus.

Create the Path

A spline will be used to create a path that goes straight
through the first torus, bends, and comes straight back through the
second one.

In the Front View, drag a guide line from the ruler at the left and
position it so it cuts the first torus in half to help you draw the straight
portions of the spline. Drag another one for the other torus. You can use
the Grid Snap option from the Snap palette to help you draw the
straight portion of the splines. You may want to turn it off for the curved
portion. With the Snap Grid selected, each point will be snapping the
the current grid values set in the Grid Preference dialog under the Edit
Menu and will limit the positioning of the vertices and the tangent line
at each vertex.
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Note: Clone can also be selected 
by holding the Command key and
pressing the W key. Move To can 
also be selected by holding the
Command key and pressing 
the M key.

Reposition torus

Clone and drag torus
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Select the Spline tool. In the Top
View, click a point directly below
the first torus and even with the
center of that torus and release
without dragging. Move the cursor
above and still even with the center
of that torus. Click and release
without dragging. This completes
the straight part of the spline. Move
the cursor up so that it sits on the
vertical Origin Line at a height of
about 1.5 inches. Don’t worry if you
run our of room at the top, the
screen will automatically scroll
down to give you more room. Click,
hold, and drag about a half inch 
to the right to give the spline a
broad bend.

To create a straight spline you click and release and move to the next
point. To make a curved spline, you click and drag the cursor to set the
desired curvature and release and move to the next point. Dragging after
placing a spline vertex, pulls the tangent at that vertex out and broadens
the curve. To make a narrower bend in the curve, click on a vertex and
first drag one end of the tangent toward the vertex and then the other.
You will notice that the ends of the tangent are not tided together. This
enables you to shorten or broaden the curve on one side of the vertex
without shortening or broadening the curve on the other side. 

Click a point directly above the first torus and even with the center of
that torus and release without dragging. Move the cursor below and still
even with the center of that torus. Click and release without dragging.
This completes the straight end of the spline. Look at the Groups
palette. You will notice the Three drawing elements you just created
listed there. 

Note: The Snap palette provide eight
snapping options: Free, Grid, Vertex,
On Contour, Marker, Midpoint, Center,
and Intersection. For a detailed
description of these options refer to the
Snap palette chapter.

Note: Refer to the Tool palette chapter
for more information on spline usage.

Spline path drawn through toruses.
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Create the Contour to be Extruded on the Path

The tube will be made to just fit inside each
torus. Select the Ellipse Tool to draw a circle which will be
the contour to be extruded along the path. Move the cursor
to the left-most part of the inside edge of the torus at the left.
Hold the Shift key down, click and drag to the right-most
part of the inside of the torus and release. You now have a
circle the exact dimension of the inside diameter of the torus.

You can leave the circle where it’s at or move it down and
away from the torus.

Perform the Path Extrude

Click on the Selector Tool (or type the letter S) and
click on the circle in the Front View to select the it as the object to be
extruded along the spline path.

Select the Path Extrude tool from the Tool pallet. Click on the On Path
button in the Path Extrude Info palette to have the extrusion start and
end exactly where the spline begins and ends.

Holding the Option key down, click on the spline drawn through the
toruses to start the path extrusion. You now have a preview of the
extruded tube. You may have to click on the Fit to Window icon in the
Top View to have the preview visible in the window.

Click on the Path Extr. button on the Path Extrude Tool Info palette to
complete the path extrusion.

Go to the File Menu and select Save As. At the prompt for a name, type
Tube.mdl.

Circle drawn to fit inside torus.

Path Extrude Info palette

Tip: It’s important to change the screen
layout and object size to fit the current
task being performed. Using
ModelPro’s window and object sizing
tools effectively will improve your
modeling productivity. Remember to
use the Zoom box, the Zoom In and
Out icons, the Fit To Window icon, and
the Hand Tool to give you the most
effective drawing space for the task at
hand. In the Angled View, the Hand
Tool can be used in two ways. Using it
normally it allows the view to be
rotated. With the Option key held
down, it can be used to scroll and pan
the screen as in the other views.
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Path extrude preview

Completed Path Extrude

Tip: If you had moved the circle inside
the torus, you could have used the 
On Contour option as well. To try it
where it is, Undo the path extrusion.
Hold the Shift key down while 
selecting the Path Extrude Tool to
reset the parameters. Otherwise, 
it will automatically do the On Path
extrusion. Click on the On Contour
button in the Path Extrude Info palette
to have the extrusion start from the
position of the circle.
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Creating a Smoother Path

Take a look at the extruded 
tube. The angle is quite sharp at the edges where
the straight spline segments meet the smooth
spline segments and the curve at the top is 
quite broad and could be more rounded. The
following will show you some ways for making 
the path smoother.

In order to smooth out the spline path, you 
first need to “undo” the previous path extrude. 
Under the Edit menu, choose Undo or hold 
the Command key downs and type Z. 
Under the Windows menu, choose 
Re-display (or hold the Command key 
downs and type D). This removes the path
extruded object from the windows and the 
Groups palette. 

Pick the Selector Tool and click on the spline.
Holding the Shift key down, click on all the
points. The reason why this path isn’t very smooth
is now clear. There is only one smooth point (the
one at the top with the tangent line showing) in
the whole spline. To make the whole curve
smoother, the two sharp-cornered vertices that
connect to the smooth segments will be converted
to smooth-cornered vertices.

The Selector Tool, with the Control key held down, is used to convert
sharp-cornered vertices to smooth-cornered vertices and vice versa. 
Hold The Control key, click, hold and drag on the vertex. As you drag,
you will see that the two segments are now joined as a continuous
smooth curve.

Selecting the vertices

Converting a sharp-cornered vertex
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You will also observe that the curve is now bent at
this point. To smooth it out, click, hold, and drag
on one of the control handles on the tangent to
move them into a vertical position.

Repeat this procedure for the other sharp-cornered
vertices. With just three smooth-edged vertices,
this gives you a much smoother curve. Refer to the
tip below to see how adding points can help create
even smoother curves.

Perform the Path Extrude

Click on the Selector Tool (or type the letter S)
and click on the circle in the Front View to 
select the it as the object to be extruded along 
the spline path.

Select the Path Extrude tool from the Tool pallet.
Make sure that the On Path option in the Path
Extrude Info palette is selected. Holding the
Option key down, click on the spline drawn
through the toruses to start the path extrusion.
You now have a preview of the smoother tube.

Click on the Path Extr. button on the Path
Extrude Tool Info palette to complete the 
path extrusion.

Go to the File Menu and select Save As. At the
prompt for a name, type Smooth Tube.mdl. Take 
a look at the tip below before you quit or continue 
on to the next part.

In order to smooth out the spline path, you need to “undo” the path
extrude. Under the Edit menu, choose Undo or hold the Command key
downs and type Z. Under the Windows menu, choose Re-display or hold
the Command key downs and type D This removes the path extruded
object from the windows and the Groups palette. 

Note: Clicking and dragging on the
control handle of a tangent to a vertex
while holding the Control key separates
the action of the handles. This allows
you to edit the curves on each side of
the vertex separately.

Lining the control handles in a 
vertical position

Completing the conversion to 
smooth-cornered vertices



E:8

To select the spline, click on the spline with the Command key held
(this lets you select objects without having to change tools). Select the
Add Vertex Tool and click twice on the spline at two different points
near and to the left of the point on the bend you want to smooth. Now
click twice on the spline at two different points close and to the right of
the point on the bend you want to smooth. This adds two points to the
left and right of the point on the bend.

Repeat the instructions in the “Perform the Path Extrude” step outlined
in this tutorial. If the bend is still “pinched”, you will need to add more
points around the bend until the path extruded object is smooth.

Preview of Path Extrude

Final extrude

Smoothing a Sharp Bend in the Path
Sometimes a “pinch” occurs on a path
extruded object where the spline has a
sharp bend. When this happens, you can
either change the spline so that it has no
sharp bends or you can add more point
around the bend.


